Plot Controller Help


Overview


This window controls how you view the models you have drawn from the database. It allows you to

  • Select what model value to display on each axis.
  • Color-code and size code additional model parameters
  • Rotate the view to any orientation
  • Zoom axes independently or in conjunction
  • Apply a function (Log or Ln) to any axis
  • View the parameters of a single point
  • Select one model for further investigation

The above schematic of this window may also be viewed by selecting Window Schematic under the Help menu.


The Plot View


DIRT Plot View
DIRT Plot View,  click to see full size.
The main area of the Plot Controller is the Plot View. The Plot View contains the actual model values (cubes) as well as any observed data that you may have added (orange spheres). The data are plotted in 3-dimensional cartesian coordinates. Initially, the axes are Frequency, Flux (Fnu), and Visual Extinction (Av), but you may select any of the available model parameters as axes.   An additional model parameter may be shown as cube size (initially this is opacity, Tau). Points may also be coded with Av or inner radius (Ri). The background may be set to a grid, opaque, or both, and any axis may be projected. The plot may be rotated with the mouse or with the wheels, and zoomed with the zoom slider.


Changing Axes


The lower portion of the window is the Axis Control area. Initially, the 3-D plot shows Frequency, Av, and Fnu logarithmically on the X,Y, & Z axes, and Tau encoded in the plot symbol size. You change these by selecting a different choice under Axis Function and pressing Apply. Similarly the axis range can be changed by moving either end of the Axis Range sliders associated with each axis and pressing Apply. The Legend area always shows current values of the extrema for each axis and the size selection. The default symbol size is changed by entering a new number in the Size textfield (including carriage return) and pressing Apply. You can make any number of changes before pressing Apply.


Color-Coding Model Parameters


Color coding panel The initial default color for the plot symbols (the little cubes) is yellow. The choice lists on the Color Code panel in the upper left allow you to modify the coloring of points based on their extinctions or inner radii. Under Color: select Ri or Av for inner radius or extinction, respectively. The choice lists below this will reflect all possible values of your Color selection. The little colored squares next to each list are the available colors. Simply set the list value next to the color in which you want to encode that value and press Apply. `Default' sets the color for unencoded values (initially yellow).

Rotating, Zooming, & Other Cool Stuff


There are two ways to actively rotate the plot.
1.   You can use the wheels in the lower right of the Plot View to rotate horizontally and vertically. The buttons below the vertical wheel and to the right of the horizontal wheel undo the last wheel movement. rotation wheels
2.   Alternatively, dragging the mouse with the Left button pressed will rotate about any axis.

zoomer To zoom, use the three-pronged slider in the lower left of the Plot View. To the left of the slider is a toggle button that allows independent or joint zooming of the axes.

toggles There are 6 toggle buttons arranged vertically below the Help menu bar. Starting from the top, the first three cause the Plot View to be projected along each of the three principal axes. The fourth resets the Plot View to the initial projection. The fifth toggles an opaque background and the sixth toggles a grid.


Querying A Point, Selecting A Model


selection of model
Model selection and point query
As the mouse (with no buttons pressed) passes over a plot point you'll notice the points change color. The point that is nearest the cursor turns black and the rest of the points associated with that particular model are highlighted in magenta. To see the parameters of the black point, click the right mouse button. To make the parameters disappear, click in a blank space with the right mouse button. To select the model for further investigation (Details and Chi-squared fitting), click with the left button. The magenta highlighting will stay lit. To deselect, click in a blank space with the left button. Once you have selected a model, the `Details' button in the Auxiliary Button panel will become enabled. The middle mouse button (if you have one) does nothing.


Filtering The Models


To limit the number of models displayed on the Plot View, you can Filter the display via any model parameter. Clicking Filter on the Auxiliary Panel (or using CTRL-F) will open a FilterBox of sliders, one for each model parameter. The sliders operate just like the sliders in the Axis Control Panel. Simply slide one or both ends of a slider and click Apply to filter the display. To unfilter, slide them back and click Apply. While, the FilterBox is open, the Axis Control Panel is disabled. You must Dismiss the FilterBox to re-enable it.

filter box

Plot View filtering in action


Adding Your Data To The Plot


To add your own data to the Plot View, click Add Data. This will open a Data Input Window, in which you may type or paste your data. The Data Input Window has menus for you the data units and flux type, so you don't have to worry about units conversion. Once you load the data, they will appear as orange circles on the Plot View when you have Fnu, Frequency, or Lambda as one of the displayed axes. You can query data points just as you do model points.
data input window
The Data Input Window


Viewing Model Details


Model details
Details plots, click to see full size.
After you select a model, pressing the Details button or typing Ctrl-E in the Plot View will bring up a window in which you can investigate model details like grain temperature and density distributions. See the Model Details help page for more information.


Chi-squared Fitting


Once you have selected a model and added your data to the plot, the ChiSq  button will become enabled. Click it to open a Chi-squared Window (or type CTRL-X). The selected model and your data will be displayed therein. Follow the instructions in the Chi-squared window help page to do the fitting.
Chi-squared window
The Chi-squared Window,
click to see full size.


The Menu Bar


The menu bar

Most windows produced by this program have a menu bar. The menu bars generally have the similar configurations each with File and Help menus, and some with Actions and Preferences. Many menu bar directives have a keyboard accelerator in the form of CTRL + some key, e.g., to quit, you can type CTRL-Q or select File-->Quit.

The following explains each menu's options.

File - Quit or Print this Plot Controller. To print, you must grant the applet permission first.

Actions - The Actions correspond to the Auxiliary Buttons (Apply, Filter, etc). In addition, `Close Aux Windows' will destroy any auxiliary windows you have opened from this Plot Controller (e.g. a Chi-squared Window)

Preferences - toggle the Axis Control panel and Information line visibility

Help - get General Help on the applet, Specific Help on this window, show a Window Schematic, or get Version information.

Dirt Help Navigation
Main Display Details Plot Data Input Chi-Squared

WITS PDRT DIRT Home DIRT Help Run DIRT

Please direct comments, criticisms, corrections and contributions to Marc Pound
Page last modified: Tuesday, 10-Jun-2003 14:24:10 EDT.